const regex = new RegExp('((?:\\w+\\.(?!keys))*(?:\\w+))\\.keys\\(\\)', 'g')
const str = `assignment_progress_header = ','.join(self.ASSIGNMENT_PROGRESS_STRUCTURE.keys()) + '\\n'
j.keys()
adasd.keys()
snallg = pop.keys()
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}