# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/\\/)(\w+)(\s+)(JOB)(\s+)(\w+)?(,)([\w+=\w+]+)//gm;t' <<< "//ADBB503 JOB ,MSGCLASS=2,CLASS=P
//ABCD JOB Something,MSG=NTNG,CLASS=ABC"