$re = '/(\/\/)(\w+)(\s+)(JOB)(\s+)(\w+)?(,)([\w+=\w+]+)/m';
$str = '//ADBB503 JOB ,MSGCLASS=2,CLASS=P
//ABCD JOB Something,MSG=NTNG,CLASS=ABC';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;