using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(b|i|u|s)\]\s*(.*?)\s*\[\/\1\]";
string input = @"[b]Text B[/b]
[i]Text I[/i]
[u]Text U[/u]
[s]Text S[/s]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}