$re = '/\[(b|i|u|s)\]\s*(.*?)\s*\[\/\1\]/mi';
$str = '[b]Text B[/b]
[i]Text I[/i]
[u]Text U[/u]
[s]Text S[/s]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);