re = /\[(b|i|u|s)\]\s*(.*?)\s*\[\/\1\]/mi
str = '[b]Text B[/b]
[i]Text I[/i]
[u]Text U[/u]
[s]Text S[/s]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end