package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(10|11|12)\b`)
var str = `10 34 12 11 200 110 22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}