$re = '/\b(10|11|12)\b/';
$str = '10 34 12 11 200 110 22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);