#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^INVALID$"
Local $sString = "TestINVALID" & @CRLF & _
"TestINVALID123" & @CRLF & _
"INVALID" & @CRLF & _
"INVALIDTest" & @CRLF & _
"this one will be valid" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")