import re
regex = re.compile(r"^INVALID$", flags=re.MULTILINE)
test_str = ("TestINVALID\n"
"TestINVALID123\n"
"INVALID\n"
"INVALIDTest\n"
"this one will be valid\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")