$re = '/^INVALID$/m';
$str = 'TestINVALID
TestINVALID123
INVALID
INVALIDTest
this one will be valid
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);