import re
regex = re.compile(r"(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+")
test_str = ("A1_aaa123\n"
"9_1aa123\n"
"A_aaa12\n"
"1_aa123\n"
"1_jjj112\n"
"2_aslk\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")