re = /(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+/
str = 'A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end