package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]){3}\s?([0-9]){3}`)
var str = `ABC 123 tab 123 tab 534
$DEF564 tab 456 tab 5454`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}