$re = '/([A-Z]){3}\s?([0-9]){3}/m';
$str = 'ABC 123 tab 123 tab 534
$DEF564 tab 456 tab 5454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);