re = /([A-Z]){3}\s?([0-9]){3}/m
str = 'ABC 123 tab 123 tab 534
$DEF564 tab 456 tab 5454'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end