#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(D|M|Y)"
Local $sString = "abc1234abc" & @CRLF & _
"123abc" & @CRLF & _
"123" & @CRLF & _
"" & @CRLF & _
"123M" & @CRLF & _
"" & @CRLF & _
"123D" & @CRLF & _
"" & @CRLF & _
"123Y" & @CRLF & _
"" & @CRLF & _
"abc123Y"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")