$re = '/^\d+(D|M|Y)/m';
$str = 'abc1234abc
123abc
123
123M
123D
123Y
abc123Y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);