package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(D|M|Y)`)
var str = `abc1234abc
123abc
123
123M
123D
123Y
abc123Y`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}