package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\b([^(or|be)])\b(?i)\b(my|be|or)\b`)
var str = `Testing for my Match.
Or for or Match.
And Be for be.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}