$re = '`(?i)\b([^(or|be)])\b(?i)\b(my|be|or)\b`m';
$str = 'Testing for my Match.
Or for or Match.
And Be for be.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);