re = /(?i)\b([^(or|be)])\b(?i)\b(my|be|or)\b/m
str = 'Testing for my Match.
Or for or Match.
And Be for be.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end