using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w-]+(?=-)";
string input = @"http://www.mywebsite.com/at/hello-everybody-mn0000000003";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}