re = /[\w-]+(?=-)/
str = 'http://www.mywebsite.com/at/hello-everybody-mn0000000003'
# Print the match result
str.match(re) do |match|
puts match.to_s
end