$re = '/[\w-]+(?=-)/';
$str = 'http://www.mywebsite.com/at/hello-everybody-mn0000000003';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);