re = /([a-zA-Z0-9]+):"(.*?)(?<!\\)"/m
str = 'joe:"Look over there\\, it\'s a shark!",sam:"I like fish."'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result