import Foundation
let pattern = #"([a-zA-Z0-9]+):"(.*?)(?<!\\)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"joe:"Look over there\, it's a shark!",sam:"I like fish.""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)