# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/vimeo.*?([0-9]+$)//gi;t' <<< "www.vimeo.com/132144170"