import re
regex = re.compile(r"vimeo.*?([0-9]+$)", flags=re.IGNORECASE)
test_str = "www.vimeo.com/132144170"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)