$re = '/vimeo.*?([0-9]+$)/i';
$str = 'www.vimeo.com/132144170';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;