$re = '/0\d-?\d{4}-?\d{4}/';
$str = '01-2345-6789
0123456789
01-23456789
012345-6789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);