using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?:(?![×Þß÷þø])[-'0-9a-zÀ-ÿ])+$";
string input = @"Ôabcéà É'-99";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}