$re = '/(?i)^(?:(?![×Þß÷þø])[-\'0-9a-zÀ-ÿ])+$/';
$str = 'Ôabcéà É\'-99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);