const regex = /(?i)^(?:(?![×Þß÷þø])[-'0-9a-zÀ-ÿ])+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(?:(?![×Þß÷þø])[-\'0-9a-zÀ-ÿ])+$', 'g')
const str = `Ôabcéà É'-99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}