#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^require_once|(?<!^)\G)[^\\]*?\K\\"
Local $sString = "no_require ab\ \ \" & @CRLF & _
"require_once $doc_root . "\inc\common.php";" & @CRLF & _
"require_once $doc_root . "\inc\admin_login.php";" & @CRLF & _
"require_once $doc_root . "\inc\usps_functions.php";" & @CRLF & _
"require_once $doc_root . '\lib\PDFMerger\PDFMerger.php';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")