re = /(?m)(?:^require_once|(?<!^)\G)[^\\]*?\K\\/
str = 'no_require ab\\ \\ \\
require_once $doc_root . "\\inc\\common.php";
require_once $doc_root . "\\inc\\admin_login.php";
require_once $doc_root . "\\inc\\usps_functions.php";
require_once $doc_root . \'\\lib\\PDFMerger\\PDFMerger.php\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end