use strict;
my $str = 'no_require ab\\ \\ \\
require_once $doc_root . "\\inc\\common.php";
require_once $doc_root . "\\inc\\admin_login.php";
require_once $doc_root . "\\inc\\usps_functions.php";
require_once $doc_root . \'\\lib\\PDFMerger\\PDFMerger.php\';';
my $regex = qr/(?m)(?:^require_once|(?<!^)\G)[^\\]*?\K\\/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}