#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:^(?:(?!hello).)*(?:\r?\n))(?=[^:]+((?(1)\1)+:\d+)))*.*hello(?=[^:]+(?:(?(1)\1)+:(\d+)))"
Local $sString = "some code" & @CRLF & _
"more code" & @CRLF & _
"hey, hello!" & @CRLF & _
"more code" & @CRLF & _
"" & @CRLF & _
":1:2:3:4:5:6:7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")