$re = '/(?m)(?:(?:^(?:(?!hello).)*(?:\r?\n))(?=[^:]+((?(1)\1)+:\d+)))*.*hello(?=[^:]+(?:(?(1)\1)+:(\d+)))/';
$str = 'some code
more code
hey, hello!
more code
:1:2:3:4:5:6:7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);