re = /(?m)(?:(?:^(?:(?!hello).)*(?:\r?\n))(?=[^:]+((?(1)\1)+:\d+)))*.*hello(?=[^:]+(?:(?(1)\1)+:(\d+)))/
str = 'some code
more code
hey, hello!
more code
:1:2:3:4:5:6:7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end