#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\baa\b).*?\1(*SKIP)(*F)|\bbb\w+\b"
Local $sString = "aabbaa" & @CRLF & _
"aa bbc aa" & @CRLF & _
"" & @CRLF & _
"bbg" & @CRLF & _
"" & @CRLF & _
"aa bbd aa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")