using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\baa\b).*?\1(*SKIP)(*F)|\bbb\w+\b";
string input = @"aabbaa
aa bbc aa
bbg
aa bbd aa";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}