$re = '/(\baa\b).*?\1(*SKIP)(*F)|\bbb\w+\b/';
$str = 'aabbaa
aa bbc aa
bbg
aa bbd aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);