using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([A-Z][A-Z0-9]*)\b[^<>]*>[^<]*</\1>";
string input = @"<B><I>bold italic</I></B> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}