$re = '/<([A-Z][A-Z0-9]*)\b[^<>]*>[^<]*</\1>/';
$str = '<B><I>bold italic</I></B> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);