const regex = new RegExp('<([A-Z][A-Z0-9]*)\\b[^<>]*>[^<]*</\\1>', '')
const str = `<B><I>bold italic</I></B> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}