package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d.,]+`)
var str = `$797.48
CHF 1,879.00
97,48 €
€1,234.48
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}