$re = '/[\d.,]+/';
$str = '$797.48
CHF 1,879.00
97,48 €
€1,234.48
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);