const regex = /[\d.,]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d.,]+', 'g')
const str = `\$797.48
CHF 1,879.00
97,48 €
€1,234.48
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}