package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?msi)(select\s.*from\s|delete\s+from\s|insert\s+into\s.*values\s|update\s.*set\s)`)
var str = `Request osmcha analysis for changeset ids and update edits table with flags.
All cs ids are passed as a parameter to the api request (in case of a large
number of changesets,they will be split into multiple lists, i.e. this will
result in multiple requests).
The flags of each changeset are aggregated and uploaded into the db.
To see possible values of reasons look at osmcha_reasons.md.
:param settings:
:return:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}